Simplefit.org • View topic - Simplefit Upgrade

Simplefit Upgrade

body weight exercise community

Moderator: cheapo

Simplefit Upgrade

Postby Admin » Sat Jul 03, 2010 12:12 pm

Sorry for the downtime I am having some major issues after an upgrade then went bad. I just reinstalled a new OS and new version of PHPBB as you can see to get around some backward compatibility issues with php and myql. If anybody knows php/mysql really well and would like to help out send me an email kevintmckay @ gmail . com

Cheers
Last edited by Admin on Sun Jul 25, 2010 9:40 am, edited 2 times in total.
Reason: Updated the title.
Admin
Site Admin
 
Posts: 1839
Joined: Tue Dec 19, 2006 7:39 pm

Re: Simplefit outage

Postby Admin » Sun Jul 04, 2010 6:07 am

Please let me know if you have any problems with this new board software, basically pumped all the old board data out of mysql converted it then pumped it back it. I did no see any errors but you never know. The logging software is hosed I will try to figure that out soon.
Admin
Site Admin
 
Posts: 1839
Joined: Tue Dec 19, 2006 7:39 pm

Re: Simplefit outage

Postby visionteacher » Tue Jul 06, 2010 10:16 am

Only problem I'm seeing so far is that its not keeping me logged in. Whenever I go to a new thread it wants my username and password in order for me to reply. This happens in both firefox and IE 8. I don't know anything about this stuff, so have no idea why its doing it. Its slightly inconvenient though not a huge issue.

~Mickey
visionteacher
Member
 
Posts: 37
Joined: Sun Jun 13, 2010 3:40 pm
Location: Tallahassee, FL

Re: Simplefit outage

Postby Admin » Tue Jul 06, 2010 12:41 pm

I get this issue as well I am looking into it.

Thanks
Admin
Site Admin
 
Posts: 1839
Joined: Tue Dec 19, 2006 7:39 pm

Re: Simplefit outage

Postby slbazo » Tue Jul 06, 2010 7:56 pm

I cannot access my log, only this area! :(
slbazo
 
Posts: 8
Joined: Fri May 28, 2010 4:44 pm

Re: Simplefit outage

Postby cheapo » Wed Jul 07, 2010 1:40 am

Read the second post in this thread.
cheapo
Senior Member
 
Posts: 778
Joined: Tue Jan 08, 2008 10:47 am
Location: Dartmouth, Nova Scotia, Canada

Re: Simplefit outage

Postby cheapo » Wed Jul 07, 2010 5:11 am

visionteacher wrote:Only problem I'm seeing so far is that its not keeping me logged in. Whenever I go to a new thread it wants my username and password in order for me to reply. This happens in both firefox and IE 8. I don't know anything about this stuff, so have no idea why its doing it. Its slightly inconvenient though not a huge issue.


Same here.

Other issues:
  1. Checking the "Log me in each time I visit SimpleFit" checkbox has no effect.
  2. The breadcrumb navigation ("Board indexsimplefitworkout logs") is odd. Clicking on either "Board index" or "simplefit" takes you to the homepage of the forum, but the "simplefit" link takes you to a homepage that is missing the supplemental navigation links ("View unanswered posts • View unread posts • View new posts • View active topics")
cheapo
Senior Member
 
Posts: 778
Joined: Tue Jan 08, 2008 10:47 am
Location: Dartmouth, Nova Scotia, Canada

Re: Simplefit outage

Postby Admin » Wed Jul 07, 2010 12:10 pm

I am working to sort this all out.
we have moved to a newer release of the OS "linux"
We have moved to a newer version of PHP php5
We have moved to a new database mysql db
We have moved to a newer version of the board software "phpbb"
We also moved to a newer version of apache "the actual http server" We are now on 2.0 I normally use 1.3 the virtual hosts setup is different so looking at that.

All in all we are on a newer more secure faster platform just need to work out the kinks


Cheers
Admin
Site Admin
 
Posts: 1839
Joined: Tue Dec 19, 2006 7:39 pm

Re: Simplefit outage

Postby cheapo » Wed Jul 07, 2010 1:41 pm

No complaints here! Just flagging things for your attention.

Is the board sluggish right now, or is it just me?
cheapo
Senior Member
 
Posts: 778
Joined: Tue Jan 08, 2008 10:47 am
Location: Dartmouth, Nova Scotia, Canada

Re: Simplefit outage

Postby visionteacher » Thu Jul 08, 2010 6:22 am

Well I'm complaining! :-) Just kidding :-) Keep up the good work for us Kevin! Thanks for what you do.

~Mickey
visionteacher
Member
 
Posts: 37
Joined: Sun Jun 13, 2010 3:40 pm
Location: Tallahassee, FL

Re: Simplefit outage

Postby Admin » Thu Jul 08, 2010 6:43 am

No I appreciate the feedback that's how I will get everything fixed keep it coming!

You should not be logged out when browsing the board now, I found a setting where the board selected the servers internal nated IP behind the firewall which I updated to the externally resolvable host name.

If you close your browser and come back it will still require a login I think that has to do with the boards session cookie and my Apache vhost config still working on this. I will devote some time sat morning to figuring it out and look at fixing logging.
Admin
Site Admin
 
Posts: 1839
Joined: Tue Dec 19, 2006 7:39 pm

Re: Simplefit outage

Postby cheapo » Thu Jul 08, 2010 6:50 am

FYI:
I cleared all cookies and closed the tab displaying SF.
I still had to log in again when I returned to the site.

Even when I leave SF open in one tab and launch it in a new tab, I have to log in again in the new tab.
cheapo
Senior Member
 
Posts: 778
Joined: Tue Jan 08, 2008 10:47 am
Location: Dartmouth, Nova Scotia, Canada

Re: Simplefit outage

Postby Admin » Thu Jul 08, 2010 7:01 am

Right, thats expected but you should not get logged out anymore when browsing within the board in the same browser tab, I think a new tab will use a new cookie its a separate issue probably a problem with my vhosts, contexts root, and the boards cookie.
Admin
Site Admin
 
Posts: 1839
Joined: Tue Dec 19, 2006 7:39 pm

Re: Simplefit outage

Postby cheapo » Thu Jul 08, 2010 7:15 am

OK. That's what I am seeing.
cheapo
Senior Member
 
Posts: 778
Joined: Tue Jan 08, 2008 10:47 am
Location: Dartmouth, Nova Scotia, Canada

Re: Simplefit outage

Postby cheapo » Thu Jul 15, 2010 4:44 am

The text of the first post in every thread is very small.
cheapo
Senior Member
 
Posts: 778
Joined: Tue Jan 08, 2008 10:47 am
Location: Dartmouth, Nova Scotia, Canada

Next

Return to fitness community

Who is online

Users browsing this forum: No registered users and 1 guest

cron